The “System.Web.Security.SqlMembershipProvider” requires a database schema compatible with schema version 1

Home Forums ASP.Net The “System.Web.Security.SqlMembershipProvider” requires a database schema compatible with schema version 1

This topic contains 0 replies, has 1 voice, and was last updated by  dotnetcode June 13, 2014 at 2:51 pm.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #85 Reply

    dotnetcode
    Keymaster
    • Topics 2
    • Replies 0
    • Total posts 2

    Error

     

    If you areĀ facing this above error and stuck into it try this possible solution.

    Run this sql query first

    INSERT INTO dbo.aspnet_SchemaVersions
    VALUES
    (‘common’, 1, 1),
    (‘health monitoring’, 1, 1),
    (‘membership’, 1, 1),
    (‘personalization’, 1, 1),
    (‘profile’, 1, 1),
    (‘role manager’, 1, 1);

    and you need to add this following in web.config

    For .net frameowork 4.0

         <roleManager enabled="true" defaultProvider="SqlProvider">
         <providers>
            <clear/>
            <add name="SqlProvider" connectionStringName="rolesDB" type="System.Web.Security.SqlRoleProvider, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
         </providers>
      </roleManager>

    for .net framework 2.0

        <roleManager enabled="true" defaultProvider="SqlProvider">
         <providers>
            <clear/>
            <add name="SqlProvider" connectionStringName="rolesDB" type="System.Web.Security.SqlRoleProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
         </providers>
      </roleManager>

    Here is web.config.

Viewing 1 post (of 1 total)
Reply To: The “System.Web.Security.SqlMembershipProvider” requires a database schema compatible with schema version 1
Your information: